summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-07-17 17:30:51 -0400
committerBrian Behlendorf <[email protected]>2020-07-22 09:59:36 -0700
commitd32a59fe2b29a7008a820d597a7efa41ccdf2f09 (patch)
treee8a87697057f7b4051f8cb09d265d0cf66d0d8a2 /Makefile.am
parent5dd92909c6d1ed606aac7c6ffe3df68513bb5ed1 (diff)
Restore scripts/make_gitrev.sh
Commit 109d2c931020 ("Move zfs_gitrev.h to build directory") removed scripts/make_gitrev.sh, putting the logic into the Makefile itself. However, at least the Arch Linux packager wants the script so that the file can be generated without having to run configure first, for DKMS packaging purposes. So move the make recipe back into the script. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Eli Schwartz <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10595
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c0114661..98cf55880 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,16 +54,7 @@ CLEANFILES = $(GITREV)
PHONY = gitrev
gitrev:
- $(AM_V_GEN)ZFS_GITREV=$$(cd $(top_srcdir) && \
- git describe --always --long --dirty 2>/dev/null); \
- ZFS_GITREV=$${ZFS_GITREV:-unknown}; \
- printf '#define\tZFS_META_GITREV "%s"\n' \
- "$${ZFS_GITREV}" >$(GITREV)~; \
- if cmp -s $(GITREV) $(GITREV)~; then \
- $(RM) $(GITREV)~; \
- else \
- mv -f $(GITREV)~ $(GITREV); \
- fi
+ $(AM_V_GEN)$(top_srcdir)/scripts/make_gitrev.sh $(GITREV)
all: gitrev