summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-12-23 21:26:19 +0100
committerTony Hutter <[email protected]>2022-09-14 11:23:25 -0700
commitc8f795ba53acfe0239bfa5d75f64dce8e390a992 (patch)
tree2875d55c6d6b7383790d36d06554f8fef7b84faa /Makefile.am
parent7bbfac9d04dc06ba339be0540fd50e5166df8516 (diff)
config: check for parallel(1), use it for cstyle
Before: $ time make cstyle real 0m23.118s user 0m23.002s sys 0m0.114s After: $ time make cstyle real 0m4.577s user 0m31.487s sys 0m0.699s Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Issue #12899
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e2b10b39..36d8cd2d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,6 +114,11 @@ commitcheck:
${top_srcdir}/scripts/commitcheck.sh; \
fi
+if HAVE_PARALLEL
+cstyle_line = -print0 | parallel -X0 ${top_srcdir}/scripts/cstyle.pl -cpP {}
+else
+cstyle_line = -exec ${top_srcdir}/scripts/cstyle.pl -cpP {} +
+endif
PHONY += cstyle
cstyle:
@find ${top_srcdir} -name build -prune \
@@ -122,7 +127,7 @@ cstyle:
! -name 'opt_global.h' ! -name '*_if*.h' \
! -name 'zstd_compat_wrapper.h' \
! -path './module/zstd/lib/*' \
- -exec ${top_srcdir}/scripts/cstyle.pl -cpP {} \+
+ $(cstyle_line)
filter_executable = -exec test -x '{}' \; -print