summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-10 17:24:59 +0200
committerBrian Behlendorf <[email protected]>2021-05-27 22:09:51 -0700
commitade8e4b7d6a4d46933c9aeb562af3aaca022690b (patch)
tree72b8bc0c498eac48cf3dcd5b702d5b5093882971 /Makefile.am
parent1a7bad542b867f51a44e094aab3079a14729409c (diff)
Widen mancheck target to all pages, fix them
mandoc: ./man/man8/zfs-mount-generator.8.in:188:2: ERROR: skipping end of block that is not open: RE mandoc: ./man/man8/zfs_ids_to_path.8:38:2: ERROR: skipping unknown macro: .LP mandoc: ./man/man8/zfs_ids_to_path.8:48:2: ERROR: inserting missing end of block: Sh breaks Bl mandoc: ./man/man8/zfs-wait.8:69:2: ERROR: skipping end of block that is not open: El mandoc: ./man/man8/zfs-program.8:460:2: ERROR: inserting missing end of block: It breaks Bd mandoc: ./man/man8/zfs-mount-generator.8:188:2: ERROR: skipping end of block that is not open: RE mandoc: ./man/man8/zstream.8:43:2: ERROR: skipping unknown macro: .LP mandoc: ./man/man8/zstream.8:107:2: ERROR: inserting missing end of block: Sh breaks Bl mandoc: ./man/man8/zstream.8:107:2: ERROR: inserting missing end of block: Sh breaks Bl make: *** [Makefile:1529: mancheck] Error 1 Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Issue #12017
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 30c61dda2..c44d64df0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -169,10 +169,8 @@ checkbashisms:
PHONY += mancheck
mancheck:
@if type mandoc > /dev/null 2>&1; then \
- find ${top_srcdir}/man/man8 -type f -name 'zfs.8' \
- -o -name 'zpool.8' -o -name 'zdb.8' \
- -o -name 'zgenhostid.8' | \
- xargs mandoc -Tlint -Werror; \
+ find ${top_srcdir}/man/man8 -type f -name '*[1-9]*' \
+ -exec mandoc -Tlint -Werror {} \+; \
else \
echo "skipping mancheck because mandoc is not installed"; \
fi