summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2021-04-15 08:53:08 -0700
committerBrian Behlendorf <[email protected]>2021-04-19 15:12:28 -0700
commit9c470dc6c0a44c2ac78e6bf4d75445087395f8ad (patch)
treefa7f38cbcb642a27059ff3be3fdeebca21f1815f /Makefile.am
parent7616fc7971beb8a5d52bc02331fb411b7bcee9a2 (diff)
Fix 'make checkbashisms` warnings
The awk command used by the checkbashisms target incorrectly adds the escape character before the ! and # characters. This results in the following warnings because these characters do not need to be escaped. awk: cmd. line:1: warning: regexp escape sequence `\!' is not a known regexp operator awk: cmd. line:1: warning: regexp escape sequence `\#' is not a known regexp operator Remove the unneeded escape character before ! and #. Valid escape sequences are: https://www.gnu.org/software/gawk/manual/html_node/Escape-Sequences.html Reviewed-by: George Melikov <[email protected]> Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #11902
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dd48b4a2c..30c61dda2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,7 +161,7 @@ checkbashisms:
-o -name '90zfs' -prune \
-o -type f ! -name 'config*' \
! -name 'libtool' \
- -exec sh -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
+ -exec sh -c 'awk "NR==1 && /#!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
else \
echo "skipping checkbashisms because checkbashisms is not installed"; \
fi