summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Moeller <[email protected]>2020-10-20 11:35:53 -0400
committerGitHub <[email protected]>2020-10-20 08:35:53 -0700
commit777b8ccc352704526b2349e6b52940333079c962 (patch)
treeae8044427eb0b0ab40c7ab846674212dd900a27e /Makefile.am
parent13d65987a9d9958de77422f5d9d25b47e486537d (diff)
Fix commitcheck on FreeBSD
Convert from bash to sh, avoid Perl regexes and \s, prune unused functions. Reviewed-by: Mateusz Piotrowski <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ryan Moeller <[email protected]> Closes #11070
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b409d2196..4aaa0ad56 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ checkbashisms:
-o -name 'make_gitrev.sh' -prune \
-o -type f ! -name 'config*' \
! -name 'libtool' \
- -exec bash -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
+ -exec sh -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
else \
echo "skipping checkbashisms because checkbashisms is not installed"; \
fi