summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-07-18 21:24:48 -0400
committerBrian Behlendorf <[email protected]>2020-07-22 10:00:40 -0700
commit59415fc9fba4796d832b1a82b5ac338df7a11510 (patch)
tree916de7492292707cc9b15614c2a9d31f7784924f /Makefile.am
parentd32a59fe2b29a7008a820d597a7efa41ccdf2f09 (diff)
Add zfs_gitrev.h to the distributed sources
Commit 109d2c931020 ("Move zfs_gitrev.h to build directory") stopped distributing zfs_gitrev.h, as it is a generated file. Add it back, with some changes in behavior. Change the logic for gitrev as follows - if the source tree is a git repository, the behavior for build is unchanged. For make dist, append -dist to the git tag in the distributed version of zfs_gitrev.h. - otherwise, check if the source tree contains zfs_gitrev.h, and use it if so, falling back to "unknown" if it doesn't exist. - clean it only in make maintainer-clean, so we don't remove it from the source tree on make clean or make distclean. This allows disted sources to track what git tag they originally came from, with the -dist suffix indicating that the code wasn't built directly from git and so might contain additional changes beyond the git tag. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Eli Schwartz <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10595
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98cf55880..96ff7d860 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,7 +50,6 @@ EXTRA_DIST += module/zfs/THIRDPARTYLICENSE.cityhash.descrip
@CODE_COVERAGE_RULES@
GITREV = include/zfs_gitrev.h
-CLEANFILES = $(GITREV)
PHONY = gitrev
gitrev:
@@ -59,6 +58,9 @@ gitrev:
all: gitrev
# Double-colon rules are allowed; there are multiple independent definitions.
+maintainer-clean-local::
+ -$(RM) $(GITREV)
+
distclean-local::
-$(RM) -R autom4te*.cache build
-find . \( -name SCCS -o -name BitKeeper -o -name .svn -o -name CVS \
@@ -76,6 +78,7 @@ all-local:
${top_builddir}/scripts/zfs-tests.sh -c
dist-hook:
+ $(AM_V_GEN)$(top_srcdir)/scripts/make_gitrev.sh -D $(distdir) $(GITREV)
$(SED) ${ac_inplace} -e 's/Release:[[:print:]]*/Release: $(RELEASE)/' \
$(distdir)/META