summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Yao <[email protected]>2012-12-17 09:43:45 -0800
committerBrian Behlendorf <[email protected]>2012-12-17 10:59:12 -0800
commit30196bfd42567a9bc3fccac8650dc2cd9f0f7c0a (patch)
tree1dc84fe6311a5eaa393482978dddbc8202bb96ec /Makefile.am
parent18e0c500a759e0131b446bfe685cd1969656e7f5 (diff)
Do not use KERNEL_DIR env var in Makefile.am
A Gentoo user reported an issue where the build system would attempt to recurse into the kernel source tree if KERNEL_DIR is set in the environment. KERNEL_DIR is an environment variable that is used when the kernel sources are in a non-standard location, so it is necessary to stop relying on it to prevent this issue. https://bugs.gentoo.org/show_bug.cgi?id=433946 Signed-off-by: Richard Yao <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6000a7d14..74c292093 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,13 +3,13 @@ include $(top_srcdir)/config/deb.am
include $(top_srcdir)/config/tgz.am
include $(top_srcdir)/config/arch.am
+SUBDIRS =
if CONFIG_USER
-USER_DIR = lib cmd scripts
+SUBDIRS += lib cmd scripts
endif
if CONFIG_KERNEL
-KERNEL_DIR = module include
+SUBDIRS += module include
endif
-SUBDIRS = $(USER_DIR) $(KERNEL_DIR)
AUTOMAKE_OPTIONS = foreign
EXTRA_DIST = autogen.sh spl.spec.in spl-modules.spec.in META DISCLAIMER