summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-03-16 00:10:10 +0100
committerBrian Behlendorf <[email protected]>2022-05-16 15:48:21 -0700
commit1467a1bb333fe78fe2532f151f3d4f4e588fb4be (patch)
tree242fc0052af80c4c8983a7b70d58804ad5f10b75 /Makefile.am
parent2a64eeb6c762aadcce5540531ac0f178ce8eea3e (diff)
module: zstd: check we don't leak symbols; regenerate symbol map
Reviewed-by: Brian Behlendorf <[email protected]> Co-authored-by: Rich Ercolani <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12988 Closes #13209 (cherry picked from commit 6ef00196db1cc6bd189eeb72df26d494a2aee889)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 34fe16ce4..7e2b10b39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,7 @@ endif
endif
PHONY += codecheck
-codecheck: cstyle shellcheck checkbashisms flake8 mancheck testscheck vcscheck
+codecheck: cstyle shellcheck checkbashisms flake8 mancheck testscheck vcscheck zstdcheck
PHONY += checkstyle
checkstyle: codecheck commitcheck
@@ -120,6 +120,7 @@ cstyle:
-o -type f -name '*.[hc]' \
! -name 'zfs_config.*' ! -name '*.mod.c' \
! -name 'opt_global.h' ! -name '*_if*.h' \
+ ! -name 'zstd_compat_wrapper.h' \
! -path './module/zstd/lib/*' \
-exec ${top_srcdir}/scripts/cstyle.pl -cpP {} \+
@@ -173,6 +174,10 @@ vcscheck:
awk '{c++; print} END {if(c>0) exit 1}' ; \
fi
+PHONY += zstdcheck
+zstdcheck:
+ @$(MAKE) -C module/zstd checksymbols
+
PHONY += lint
lint: cppcheck paxcheck