summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Moeller <[email protected]>2019-08-26 14:48:31 -0400
committerBrian Behlendorf <[email protected]>2019-08-26 11:48:31 -0700
commit142f84dd19f20b47157bbbf45aaba489b6577c88 (patch)
tree2476b46f8f8d2f0c72fc5365e1c183ec7b61f37b /Makefile.am
parent95f0144675dd0e18617355443be0fbc7171af76b (diff)
Restore :: in Makefile.am
The double-colon looked like a typo, but it's actually an obscure feature. Rules with :: may appear multiple times and are run independently of one another in the order they appear. The use of :: for distclean-local was conventional, not accidental. Add comments to indicate the intentional use of double-colon rules. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ryan Moeller <[email protected]> Closes #9210
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index da4f6407d..3992fe9ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,7 +44,8 @@ gitrev:
BUILT_SOURCES = gitrev
-distclean-local:
+# Double-colon rules are allowed; there are multiple independent definitions.
+distclean-local::
-$(RM) -R autom4te*.cache
-find . \( -name SCCS -o -name BitKeeper -o -name .svn -o -name CVS \
-o -name .pc -o -name .hg -o -name .git \) -prune -o \