summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-21 23:43:38 +0200
committerBrian Behlendorf <[email protected]>2021-06-09 13:05:34 -0700
commit132240507d0ab2999e764537b181e89ecc3c2b0e (patch)
tree3450e3a8132bbdc611944445146f259e541a0261 /Makefile.am
parentd6f8f41c21b42a1b5a36850c0f7b18be9a05ecd9 (diff)
Turn shellcheck into a normal make target. Fix new files it caught
This checks every file it checked (and a few more), but explicitly instead of "if it works it works" best-effort (which wasn't that good anyway) Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #10512 Closes #12101
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 689816bdc..4fd3f9b3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+include $(top_srcdir)/config/Shellcheck.am
+
ACLOCAL_AMFLAGS = -I config
SUBDIRS = include
@@ -123,17 +125,8 @@ cstyle:
filter_executable = -exec test -x '{}' \; -print
-PHONY += shellcheck
-shellcheck:
- @if type shellcheck > /dev/null 2>&1; then \
- shellcheck --exclude=SC1090,SC1117,SC1091 --format=gcc \
- $$(find ${top_srcdir} -name "config*" -prune -name tests -prune \
- -o -name "*.sh" -o -name "*.sh.in" -type f) \
- $$(find ${top_srcdir}/cmd/zpool/zpool.d/* \
- -type f ${filter_executable}); \
- else \
- echo "skipping shellcheck because shellcheck is not installed"; \
- fi
+SHELLCHECKDIRS = cmd contrib etc scripts tests
+SHELLCHECKSCRIPTS = autogen.sh
PHONY += checkabi storeabi
checkabi: lib