summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-03-17 14:55:59 -0700
committerBrian Behlendorf <[email protected]>2009-03-17 14:55:59 -0700
commit0cbaeb117ae0e77d05c7709a4f5dbfad9daa799f (patch)
tree81a09cc96cc7ad76168081200834ac03614fae82 /Makefile.am
parente11d6c5f50ff1cb9a75f5c6a6895846f73564422 (diff)
Allow spl_config.h to be included by dependant packages
We need dependent packages to be able to include spl_config.h so they can leverage the configure checks the SPL has done. This is important because several of the spl headers need the results of these checks to work properly. Unfortunately, the autoheader build product is always private to a particular build and defined certain common things. (PACKAGE, VERSION, etc). This prevents other packages which also use autoheader from being include because the definitions conflict. To avoid this problem the SPL build system leverage AH_BOTTOM to include a spl_unconfig.h at the botton of the autoheader build product. This custom include undefs all known shared symbols to prevent the confict. This does however mean that those definition are also not availble to the SPL package either. The SPL package therefore uses the equivilant SPL_META_* definitions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 37182fe7f..63d6ba7e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ SUBDIRS = lib cmd module include scripts
AUTOMAKE_OPTIONS = foreign dist-zip
EXTRA_DIST = autogen.sh spl.spec.in META DISCLAIMER
-noinst_HEADERS = spl_config.h
+noinst_HEADERS = spl_config.h spl_unconfig.h
distclean-local::
-$(RM) -R autom4te*.cache
@@ -17,6 +17,7 @@ distclean-local::
install-data-local:
$(INSTALL) -D spl_config.h $(DESTDIR)/$(LINUX)/include/spl/spl_config.h
+ $(INSTALL) -D spl_unconfig.h $(DESTDIR)/$(LINUX)/include/spl/spl_unconfig.h
ctags:
$(RM) $(top_srcdir)/tags