summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2010-09-01 12:54:51 -0700
committerBrian Behlendorf <[email protected]>2010-09-01 15:42:32 -0700
commit1ae93745d2eadcdfdf1ab677180f28922e7c7d26 (patch)
treeb1f9ec0a398bdbda7c893e8a16bbe46437142b88 /Makefile.am
parent9691eb9fee92301869ae34f750279f93504f7db1 (diff)
Minor packaging fixes
The GIT file was removed from the tree because I have stopped using TopGit. Because of this is must also be removed from the top level Makefile.am as will as the zfs.spec.in file which referenced it. Fix type in lib/libzpool/Makefile.am which was preventing the needed zrlock.h header from being included by 'make dist'. I simply had the name wrong in the Makefile.am. Regenerated autogen.sh build products. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3689d1f8f..5a0791b44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ SUBDIRS = $(USER_DIR) $(KERNEL_DIR)
AUTOMAKE_OPTIONS = foreign dist-zip
EXTRA_DIST = autogen.sh zfs.spec.in zfs-modules.spec.in
EXTRA_DIST += config/config.awk config/rpm.am config/deb.am config/tgz.am
-EXTRA_DIST += META DISCLAIMER COPYRIGHT GIT README.markdown
+EXTRA_DIST += META DISCLAIMER COPYRIGHT README.markdown
EXTRA_DIST += OPENSOLARIS.LICENSE ZFS.RELEASE
noinst_HEADERS = zfs_config.h
@@ -24,11 +24,10 @@ distclean-local::
-o -name .pc -o -name .hg -o -name .git \) -prune -o \
\( -name '*.orig' -o -name '*.rej' -o -name '*~' \
-o -name '*.bak' -o -name '#*#' -o -name '.*.orig' \
- -o -name '.*.rej' -o -name 'aclocal.m4' -o -size 0 \
+ -o -name '.*.rej' -o -name '.script-config' -o -size 0 \
-o -name '*%' -o -name '.*.cmd' -o -name 'core' \
-o -name 'Makefile' -o -name 'Module.symvers' \
- -o -name '*.order' -o -name '*.markers' \
- -o -name '.script-config' \) \
+ -o -name '*.order' -o -name '*.markers' \) \
-type f -print | xargs $(RM)
if CONFIG_KERNEL