summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-06-26 18:27:30 -0400
committerBrian Behlendorf <[email protected]>2020-06-27 17:40:15 -0700
commit2b5f3045ae9c3a6f953d4cd5ed5be1b898809fdf (patch)
tree894e5969f7017eac321ff473bbac18136084366a /Makefile.am
parentc79907f90174842fb5213893e476e5d5f5b44eca (diff)
paxcheck needs to run against the builddir not the srcdir
Otherwise it does nothing on an out-of-tree build. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10506
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 432e04c07..d0c0a1648 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -186,7 +186,7 @@ cppcheck:
paxcheck:
@if type scanelf > /dev/null 2>&1; then \
- ${top_srcdir}/scripts/paxcheck.sh ${top_srcdir}; \
+ ${top_srcdir}/scripts/paxcheck.sh ${top_builddir}; \
else \
echo "skipping paxcheck because scanelf is not installed"; \
fi