summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-06-21 22:13:02 -0400
committerBrian Behlendorf <[email protected]>2020-06-24 18:19:44 -0700
commit0b03254830a79ed0784b517467442ad38404de74 (patch)
tree4fa2e1f3e31892fc099a8bba842ba0bb91368145 /Makefile.am
parent2989d1012ac00b4134a0dc490917e0b0d048d289 (diff)
Fix tags targets in module/Makefile.in + cleanup
These targets look to have been copied from an automake-generated Makefile.in, and can't work since none of the auto-generated automake variables are defined here. Moreover, ctags has been overridden in the top-level Makefile, so the target is pointless anyway, and gtags is not a recursive target. Fix cscopelist by moving it to the top-level Makefile as well, in line with ctags and etags. Also, add -a to ctags command as well, otherwise it won't work if more than one xargs invocation takes place. Add assembler files to ctags/etags, prune all dotted-dirs, and restrict the find to files only. Cleanup: add .PHONY to module/Makefile.in, and fix one recipe with a missing continuation character. Reviewed-by: Ryan Moeller <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10493
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a90c71ee9..597fc19b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -194,11 +194,17 @@ flake8:
ctags:
$(RM) tags
- find $(top_srcdir) -name .git -prune -o -name '*.[hc]' | xargs ctags
+ find $(top_srcdir) -name '.?*' -prune \
+ -o -type f -name '*.[hcS]' -print | xargs ctags -a
etags:
$(RM) TAGS
- find $(top_srcdir) -name .pc -prune -o -name '*.[hc]' | xargs etags -a
+ find $(top_srcdir) -name '.?*' -prune \
+ -o -type f -name '*.[hcS]' -print | xargs etags -a
+
+cscopelist:
+ find $(top_srcdir) -name '.?*' -prune \
+ -o -type f -name '*.[hc]' -print >cscope.files
tags: ctags etags