summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2017-09-15 10:24:13 -0700
committerGitHub <[email protected]>2017-09-15 10:24:13 -0700
commitd9ec8b9b2a3880a1a2b68e57a25833486c3b164d (patch)
tree5378af5ce8db5338fe9432eab8e485408001525b /Makefile.am
parent0107f69898e3b6d39d974b272da1739cb2f39027 (diff)
Add configure option to enable gcov analysis
* Add configure option to enable gcov analysis. * Includes a few minor ctime fixes. * Add codecov.yml configuration. Reviewed-by: Prakash Surya <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #6642
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e6e19d6a2..ed753c81a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,8 @@ distclean-local::
-o -name '*.bak' -o -name '#*#' -o -name '.*.orig' \
-o -name '.*.rej' -o -size 0 -o -name '*%' -o -name '.*.cmd' \
-o -name 'core' -o -name 'Makefile' -o -name 'Module.symvers' \
- -o -name '*.order' -o -name '*.markers' \) \
+ -o -name '*.order' -o -name '*.markers' -o -name '*.gcda' \
+ -o -name '*.gcno' \) \
-type f -print | xargs $(RM)
dist-hook: