summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Ahrens <[email protected]>2018-10-04 13:10:10 -0700
committerBrian Behlendorf <[email protected]>2018-10-04 13:10:10 -0700
commitc23f8d4829ce50e92b60f69b3b80e5301db476b2 (patch)
treeff4518b532dc96223d3f4180585a23116c4e7511 /Makefile.am
parent6e8b268875ff2bad66b797d1094a6eb1b694206a (diff)
Add codecheck make target
We'd like to have tooling that verifies code style, while ignoring the commit message. For example, code does not need to be signed off in order to be tested. Current workarounds are to run `git checkstyle` and ignore the commit message errors, or to run `make cstyle shellcheck flake8 mancheck testscheck`, and make sure that list stays updated. Solution is to add a new make target, `codecheck` which does all the code checks. `checkstyle` is now simply `codecheck` + `commitcheck`. Reviewed-by: Giuseppe Di Natale <[email protected]> Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Reviewed by: Pavel Zakharov <[email protected]> Signed-off-by: Matthew Ahrens <[email protected]> Closes #7985
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f2cd574a9..61bf9e235 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,7 +61,9 @@ install-data-hook:
ln -fs zfs.release spl.release
endif
-checkstyle: cstyle shellcheck flake8 commitcheck mancheck testscheck
+codecheck: cstyle shellcheck flake8 mancheck testscheck
+
+checkstyle: codecheck commitcheck
commitcheck:
@if git rev-parse --git-dir > /dev/null 2>&1; then \