summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2021-05-22 01:45:40 +0200
committerBrian Behlendorf <[email protected]>2021-06-09 13:05:34 -0700
commit91bb2e91bd8323fd616c6a5c503fe430bc61ef73 (patch)
tree9a37dc3d3aa0926ebf6935bea1a0ec42fcc0f4aa /Makefile.am
parent132240507d0ab2999e764537b181e89ecc3c2b0e (diff)
Turn checkbashisms into a make target
make_gitrev.sh actually breaks checkbashisms' parser, which /insists/ that the end-of-line " is actually a string start Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12101
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 0 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index 4fd3f9b3d..8e4fffc5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,31 +135,6 @@ checkabi: lib
storeabi: lib
$(MAKE) -C lib storeabi
-PHONY += checkbashisms
-checkbashisms:
- @if type checkbashisms > /dev/null 2>&1; then \
- checkbashisms -n -p -x \
- $$(find ${top_srcdir} \
- -name '.git' -prune \
- -o -name 'build' -prune \
- -o -name 'tests' -prune \
- -o -name 'config' -prune \
- -o -name 'zed-functions.sh*' -prune \
- -o -name 'zfs-import*' -prune \
- -o -name 'zfs-mount*' -prune \
- -o -name 'zfs-zed*' -prune \
- -o -name 'smart' -prune \
- -o -name 'paxcheck.sh' -prune \
- -o -name 'make_gitrev.sh' -prune \
- -o -name '90zfs' -prune \
- -o -path '*initramfs/hooks' -prune \
- -o -type f ! -name 'config*' \
- ! -name 'libtool' \
- -exec awk 'FNR==1 && /^#!.*bin\/sh/ {print FILENAME}' {} \+); \
- else \
- echo "skipping checkbashisms because checkbashisms is not installed"; \
- fi
-
PHONY += mancheck
mancheck:
@if type mandoc > /dev/null 2>&1; then \