summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <behlendorf1@llnl.gov>2008-12-05 09:46:11 -0800
committerBrian Behlendorf <behlendorf1@llnl.gov>2008-12-05 09:46:11 -0800
commit9baaa468acda39ad4de75f6d68a0e9c41860489b (patch)
tree73fdb020410e68aaba5ebfd4870abe9fa8c8ee62 /Makefile.am
parent9364d361b85396e24e06297ec24bce2dfb99d2c3 (diff)
Refresh zfs-branch
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..39f3fd084
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,25 @@
+AUTOMAKE_OPTIONS = foreign dist-zip
+
+SUBDIRS = doc scripts $(BUILDDIR)
+CONFIG_CLEAN_FILES = aclocal.m4 config.guess config.sub
+CONFIG_CLEAN_FILES += depcomp missing mkinstalldirs
+EXTRA_DIST = autogen.sh
+
+.PHONY: quilt
+quilt: .quilt-$(BUILDDIR)
+autogen: .autogen-$(BUILDDIR)
+config: .config-$(BUILDDIR)
+.quilt-$(BUILDDIR):
+ ./scripts/quilt.sh -p $(NAME) -b $(BUILDDIR) -s $(SERIESFILE) -d $(PATCHDIR)
+ echo $(BUILDDIR) >$@
+
+unquilt:
+ rm -rf $(BUILDDIR)
+ rm -f .quilt-$(BUILDDIR)
+
+clean-generic:
+
+distclean: unquilt
+
+rpms: dist Makefile
+ rpmbuild -ta $(distdir).tar.gz