summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeal Gompa (ニール・ゴンパ) <[email protected]>2017-10-15 16:00:44 -0400
committerBrian Behlendorf <[email protected]>2017-10-15 13:00:44 -0700
commit7670f721fc82e6cdcdd31f83760a79b6f2f2b998 (patch)
tree44c77d224f5f134c5e9ce0680f3b75215b4fc9b4 /Makefile.am
parentc616dcf8bc3b2cb2dddc9b8f8bc64f307c9fb938 (diff)
Add DKMS package on Debian-based distributions
* config/deb.am: Enable building DKMS packages for Debian * rpm/generic/zfs-dkms.spec.in: Adjust spec to be Debian-compatible * Condition kernel-devel Req to RPM distros * Adjust the DKMS Req to have a minimum of a version only * Ensure that --rpm_safe_upgrade isn't used on non-RPM distros * config/deb.am: Drop CONFIG_KERNEL and CONFIG_USER guards * Makefile.am: Add pkg-dkms target Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Neal Gompa <[email protected]> Closes #6044 Closes #6731
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 53a852832..c51be2b4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,5 +98,6 @@ etags:
tags: ctags etags
pkg: @DEFAULT_PACKAGE@
+pkg-dkms: @DEFAULT_PACKAGE@-dkms
pkg-kmod: @DEFAULT_PACKAGE@-kmod
pkg-utils: @DEFAULT_PACKAGE@-utils