aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-02-21 15:10:11 -0800
committerBrian Behlendorf <[email protected]>2013-03-13 13:42:16 -0700
commit775f2d34a3ccd5f866cfa04be76f83cb562f3881 (patch)
tree8bed94037a291b6cd2a2e40cb50bb9b28fb20e55 /Makefile.am
parentd69b2dee714f732300c6db12b7af48b4f86d67ee (diff)
Change zfs-kmod-devel install path
Install the common zfs kernel development headers under /usr/src/zfs-<version>/ rather than in a kernel specific directory. The kernel specific build products such as zfs_config.h and Modules.symvers are left installed under /usr/src/zfs-<version>/<kernel>. This was done to be consistent with where dkms expects kernel module source to be packaged. It also allows for a common zfs-kmod-devel package which includes the headers, and per-kernel zfs-kmod-devel-<kernel> packages. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index ca8a41939..c0e82eb68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,12 @@ SUBDIRS += dracut udev etc man scripts lib cmd
endif
if CONFIG_KERNEL
SUBDIRS += module
+
+extradir = /usr/src/zfs-$(VERSION)
+extra_HEADERS = zfs.release.in zfs_config.h.in
+
+kerneldir = /usr/src/zfs-$(VERSION)/$(LINUX_VERSION)
+nodist_kernel_HEADERS = zfs.release zfs_config.h module/$(LINUX_SYMBOLS)
endif
AUTOMAKE_OPTIONS = foreign
@@ -15,7 +21,6 @@ EXTRA_DIST = autogen.sh zfs.spec.in zfs-modules.spec.in
EXTRA_DIST += config/config.awk config/rpm.am config/deb.am config/tgz.am
EXTRA_DIST += META DISCLAIMER COPYRIGHT README.markdown OPENSOLARIS.LICENSE
EXTRA_DIST += dkms.postinst copy-builtin
-noinst_HEADERS = zfs_config.h zfs.release
distclean-local::
-$(RM) -R autom4te*.cache
@@ -29,15 +34,6 @@ distclean-local::
-o -name '*.order' -o -name '*.markers' \) \
-type f -print | xargs $(RM)
-if CONFIG_KERNEL
-install-data-local:
- release=$(ZFS_META_VERSION)-$(ZFS_META_RELEASE); \
- instdest=$(DESTDIR)/usr/src/zfs-$$release/$(LINUX_VERSION); \
- for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
- $(INSTALL) -m 644 -D $$instfile $$instdest/$$instfile; \
- done
-endif
-
ctags:
$(RM) $(top_srcdir)/tags
find $(top_srcdir) -name .git -prune -o -name '*.[hc]' | xargs ctags