aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-04-09 19:19:09 +0200
committerBrian Behlendorf <[email protected]>2022-05-10 10:19:10 -0700
commit0f6c4fd00ef7ae320860f792b17f103166511507 (patch)
treea816535e135bb9162c39341485f604715541b3fa /Makefile.am
parent0a8b1fc6251af5d16d9f87ce696ec6f04edaba31 (diff)
autoconf: use include directives instead of recursing down man
Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13316
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 514439584..89f258a1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,10 +17,11 @@ endif
CPPCHECKDIRS += etc/systemd/system-generators
if CONFIG_USER
-SUBDIRS += . man tests etc contrib
-include $(srcdir)/%D%/scripts/Makefile.am
-include $(srcdir)/%D%/lib/Makefile.am
+SUBDIRS += . tests etc contrib
include $(srcdir)/%D%/cmd/Makefile.am
+include $(srcdir)/%D%/lib/Makefile.am
+include $(srcdir)/%D%/man/Makefile.am
+include $(srcdir)/%D%/scripts/Makefile.am
if BUILD_LINUX
SUBDIRS += udev
endif
@@ -129,7 +130,7 @@ SHELLCHECKSCRIPTS += autogen.sh
PHONY += mancheck
mancheck:
- ${top_srcdir}/scripts/mancheck.sh ${top_srcdir}/man ${top_srcdir}/tests/test-runner/man
+ $(top_srcdir)/scripts/mancheck.sh $(top_srcdir)/man $(top_srcdir)/tests/test-runner/man
PHONY += testscheck
testscheck: