aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-02-13 14:01:00 -0800
committerBrian Behlendorf <[email protected]>2013-03-01 16:55:06 -0800
commitd1142fbffe720cd5f82691d7a00816ce72f4e2b2 (patch)
treefc19d2bf74f9c11029e3b4222f333426913cccb3 /Makefile.am
parent0298f3d67ff4971513ff848d640ca431a983de43 (diff)
Remove custom install-data-local for headers
Rather than use a custom install target it is cleaner to define a 'kerneldir' and set 'kernel_HEADERS' appropriately. This allows us to leverage the standing configure install support. Additionally, I took this opertunity add the missing make files to the include subdirectories. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1210c6d6b..3a6b61438 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,12 +3,12 @@ include $(top_srcdir)/config/deb.am
include $(top_srcdir)/config/tgz.am
include $(top_srcdir)/config/arch.am
-SUBDIRS =
+SUBDIRS = include
if CONFIG_USER
SUBDIRS += lib cmd scripts
endif
if CONFIG_KERNEL
-SUBDIRS += module include
+SUBDIRS += module
endif
AUTOMAKE_OPTIONS = foreign