aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-03-31 09:33:38 -0700
committerBrian Behlendorf <[email protected]>2017-03-31 09:33:38 -0700
commitcb524aa23aa6f5bc4242e3b585a58bdd3292ae0f (patch)
treee23dbe898362eac3151bb67990e97974070874d5 /Makefile.am
parent10cb2e0a19e46ecfe1378ccf79e71d986936f17e (diff)
Commit message format in contributing guidelines
Add the need to have a commit message with a specific format to the contributing guidelines. Provide a script to help enforce commit message style. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: George Melikov <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #5943
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3adc161ad..cea264acf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,12 @@ dist-hook:
sed -i 's/Release:[[:print:]]*/Release: $(RELEASE)/' \
$(distdir)/META
-checkstyle: cstyle shellcheck flake8
+checkstyle: cstyle shellcheck flake8 commitcheck
+
+commitcheck:
+ @if git rev-parse --git-dir > /dev/null 2>&1; then \
+ scripts/commitcheck.sh; \
+ fi
cstyle:
@find ${top_srcdir} -name '*.[hc]' ! -name 'zfs_config.*' \
@@ -51,6 +56,7 @@ shellcheck:
scripts/zloop.sh \
scripts/zfs-tests.sh \
scripts/zfs.sh; \
+ scripts/commitcheck.sh; \
(find cmd/zed/zed.d/*.sh -type f) | \
grep -v 'zfs-script-config' | \
while read file; do \