aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-03-31 17:20:50 +0200
committerBrian Behlendorf <[email protected]>2022-04-20 13:28:24 -0700
commitad9e767657c3d3c0ec9e09a17f6732bcbf915401 (patch)
treeb0a3ac3281ac5bf3dcf3e182caec218b8d426e29 /Makefile.am
parent310ab9d2610493f27fa624b295293a503828d48d (diff)
linux: module: weld all but spl.ko into zfs.ko
Originally it was thought it would be useful to split up the kmods by functionality. This would allow external consumers to only load what was needed. However, in practice we've never had a case where this functionality would be needed, and conversely managing multiple kmods can be awkward. Therefore, this change merges all but the spl.ko kmod in to a single zfs.ko kmod. Reviewed-by: Tony Hutter <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #13274
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 098357902..acfd83bec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -167,7 +167,7 @@ vcscheck:
PHONY += zstdcheck
zstdcheck:
- @$(MAKE) -C module/zstd checksymbols
+ @$(MAKE) -C module check-zstd-symbols
PHONY += lint
lint: cppcheck paxcheck