aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <[email protected]>2022-03-16 00:10:10 +0100
committerGitHub <[email protected]>2022-03-15 16:10:10 -0700
commit6ef00196db1cc6bd189eeb72df26d494a2aee889 (patch)
treecc10721240021bbd968ba948910e4b3995c2c9ba /Makefile.am
parent1c41d8941cb5a76d71930d2af976c376c05ed318 (diff)
module: zstd: check we don't leak symbols; regenerate symbol map
Reviewed-by: Brian Behlendorf <[email protected]> Co-authored-by: Rich Ercolani <[email protected]> Signed-off-by: Ahelenia Ziemiańska <[email protected]> Closes #12988 Closes #13209
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 42330440a..098357902 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,7 @@ endif
endif
PHONY += codecheck
-codecheck: cstyle shellcheck checkbashisms flake8 mancheck testscheck vcscheck
+codecheck: cstyle shellcheck checkbashisms flake8 mancheck testscheck vcscheck zstdcheck
PHONY += checkstyle
checkstyle: codecheck commitcheck
@@ -125,6 +125,7 @@ cstyle:
-o -type f -name '*.[hc]' \
! -name 'zfs_config.*' ! -name '*.mod.c' \
! -name 'opt_global.h' ! -name '*_if*.h' \
+ ! -name 'zstd_compat_wrapper.h' \
! -path './module/zstd/lib/*' \
! -path './include/sys/lua/*' \
! -path './module/lua/l*.[ch]' \
@@ -164,6 +165,10 @@ vcscheck:
awk '{c++; print} END {if(c>0) exit 1}' ; \
fi
+PHONY += zstdcheck
+zstdcheck:
+ @$(MAKE) -C module/zstd checksymbols
+
PHONY += lint
lint: cppcheck paxcheck