aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-06-26 16:30:44 -0700
committerBrian Behlendorf <[email protected]>2009-06-26 16:30:44 -0700
commitf4f9cd75a1e4654bf50cac6dbb5496ba93bb1662 (patch)
tree39afab86468a1e1f68b412027d0e3dcbd8a5b8b9 /Makefile.am
parentc0517c35d244beea61ff443f1e6e7229ef6337fe (diff)
Install spl-devel products in /usr/src/spl-SPL_VERSION/LINUX_VERSION/
Remove the spl symlink, it's just confusing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b7aed778e..022430361 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,11 +16,11 @@ distclean-local::
-type f -print | xargs $(RM)
install-data-local:
- instdest=$(DESTDIR)/${prefix}/src/spl-$(SPL_META_VERSION); \
+ destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
+ instdest=$(DESTDIR)/${prefix}/src/$$destname; \
for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \
done
- (cd $(DESTDIR)/${prefix}/src && ln -f -s spl-$(SPL_META_VERSION) spl)
ctags:
$(RM) $(top_srcdir)/tags