aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-09-19 12:17:29 -0700
committerBrian Behlendorf <[email protected]>2017-09-19 12:17:29 -0700
commit34d00e7aba13076e47dbd1791bd955c1e2f7b0c9 (patch)
tree4fca38c567b350660e6f2d6d53951bc356a2bb47 /Makefile.am
parent8e2dddab421e7131b7bd7eadd517fb36b59b2ddd (diff)
Correct cppcheck errors
ZFS buildbot STYLE builder was moved to Ubuntu 17.04 which has a newer version of cppcheck. Handle the new cppcheck errors. uu_* functions removed in this commit were unused and effectively dead code. They are now retired. Reviewed-by: George Melikov <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #6653
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 34f740c57..583b08b57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,8 +69,10 @@ lint: cppcheck paxcheck
cppcheck:
@if type cppcheck > /dev/null 2>&1; then \
- cppcheck --inline-suppr --quiet --force --error-exitcode=2 \
- ${top_srcdir}; \
+ cppcheck --quiet --force --error-exitcode=2 \
+ --suppressions-list=.github/suppressions.txt \
+ -UHAVE_SSE2 -UHAVE_AVX512F \
+ ${top_srcdir}; \
fi
paxcheck: