aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2021-04-15 08:53:08 -0700
committerTony Hutter <[email protected]>2021-06-23 13:22:14 -0700
commitf36e8118fd9700c0cef8536d9dfde7c37dea2525 (patch)
tree3b5b0499ad77c3d1c607bcfe6399230a317d60ac /Makefile.am
parente69f73c5cf934f1ffe0faa60072f3a74ff6643e5 (diff)
Fix 'make checkbashisms` warnings
The awk command used by the checkbashisms target incorrectly adds the escape character before the ! and # characters. This results in the following warnings because these characters do not need to be escaped. awk: cmd. line:1: warning: regexp escape sequence `\!' is not a known regexp operator awk: cmd. line:1: warning: regexp escape sequence `\#' is not a known regexp operator Remove the unneeded escape character before ! and #. Valid escape sequences are: https://www.gnu.org/software/gawk/manual/html_node/Escape-Sequences.html Reviewed-by: George Melikov <[email protected]> Reviewed-by: Ryan Moeller <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #11902
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 436b78d76..56f6ad4a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,7 +162,7 @@ checkbashisms:
-o -name '90zfs' -prune \
-o -type f ! -name 'config*' \
! -name 'libtool' \
- -exec sh -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
+ -exec sh -c 'awk "NR==1 && /#!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
else \
echo "skipping checkbashisms because checkbashisms is not installed"; \
fi