aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPrakash Surya <[email protected]>2012-07-11 15:47:56 -0700
committerBrian Behlendorf <[email protected]>2012-07-12 12:13:47 -0700
commitd801db1487205365b268efab4700e3541adab493 (patch)
treeb87e1b126451ceed38f9027fb5ba8a956f6cc14b /Makefile.am
parent36811b4430aaea8c8b91bbe7d812a26799865499 (diff)
Move spl.release generation to configure step
Previously, the spl.release file was created at 'make install' time. This is slightly problematic when the file is needed without running 'make install'. Because of this, the step creating the file was removed from 'make install' and replaced with a more appropriate spl.release.in file. As a result, the spl.release file will now be created earlier as part of the 'configure' step as opposed to the 'make install' step. Signed-off-by: Prakash Surya <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #135
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 209925969..490d12802 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,7 @@ SUBDIRS = $(USER_DIR) $(KERNEL_DIR)
AUTOMAKE_OPTIONS = foreign
EXTRA_DIST = autogen.sh spl.spec.in spl-modules.spec.in META DISCLAIMER
EXTRA_DIST += config/config.awk config/rpm.am config/deb.am config/tgz.am
-noinst_HEADERS = spl_config.h
+noinst_HEADERS = spl_config.h spl.release
distclean-local::
-$(RM) -R autom4te*.cache
@@ -32,7 +32,6 @@ if CONFIG_KERNEL
install-data-local:
release=$(SPL_META_VERSION)-$(SPL_META_RELEASE); \
instdest=$(DESTDIR)/usr/src/spl-$$release/$(LINUX_VERSION); \
- echo "$$release" >$$instdest/spl.release; \
for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \
done