aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Ahrens <[email protected]>2018-05-21 10:36:59 -0700
committerBrian Behlendorf <[email protected]>2018-05-21 10:36:59 -0700
commita430cef9cd6cbff7d9827b37c1cb322aaa1bf9dc (patch)
treeb5eb05d7f1d1a2083c53262f68ef6923eb48ec04 /Makefile.am
parent43eb39d6ccd8fbaa5ae3a84a6df549331db4d6be (diff)
Create "bin" directory so that zloop.sh works
Before running zloop.sh, we need to run `scripts/zfs-tests.sh -c` to create and populate the `bin` directory with symlinks to our utilities. Rather than making developers remember to do this, `make` should do it for them. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Matthew Ahrens <[email protected]> Closes #7525 Closes #7547
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 90a1c9475..20f790328 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,9 @@ distclean-local::
-o -name '*.gcno' \) \
-type f -print | xargs $(RM)
+all-local:
+ -${top_srcdir}/scripts/zfs-tests.sh -c
+
dist-hook:
sed -i 's/Release:[[:print:]]*/Release: $(RELEASE)/' \
$(distdir)/META