aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2012-01-17 16:14:35 -0800
committerBrian Behlendorf <[email protected]>2012-01-18 11:06:26 -0800
commita2eda2ff48e6c38788d48b121f36ff7d280d569b (patch)
treea2fa9575010e8a639c565079f203fc393b0a432c /Makefile.am
parentec2b41049f7f576aaa772b326d083e5971212d33 (diff)
Add the release component to headers
When the original build system code was added the release component was accidentally omited from the development header install path. This patch adds the missing path component so it's always clear exactly what release your compiling against. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 11fa8ec18..209925969 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,9 +30,9 @@ distclean-local::
if CONFIG_KERNEL
install-data-local:
- destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
- instdest=$(DESTDIR)/usr/src/$$destname; \
- echo "$(SPL_META_VERSION)" >$$instdest/spl.release; \
+ release=$(SPL_META_VERSION)-$(SPL_META_RELEASE); \
+ instdest=$(DESTDIR)/usr/src/spl-$$release/$(LINUX_VERSION); \
+ echo "$$release" >$$instdest/spl.release; \
for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \
done