aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLOLi <[email protected]>2018-02-07 21:43:24 +0100
committerBrian Behlendorf <[email protected]>2018-02-07 12:43:24 -0800
commit9ca25e709b904ab9669724d53eb50ee074c09705 (patch)
treeebd6e8bca66e0865ddb30544ba183621424424ab /Makefile.am
parent6b810d04bda3f274c7835e313a0dfc6938487772 (diff)
Verify ZFS Test Suite scripts executability
This change adds a make target 'testscheck' which verifies all ksh test scripts, part of the ZFS Test Suite, have their executable bit set: this should avoid adding new test scripts that cannot be executed by the test-runner.py which would result in the following warning message: Warning: Test removed from TestGroup because it failed verification. This also verifies both *.cfg and *.kshlib files used in the ZFS Test Suite are not executable. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Giuseppe Di Natale <[email protected]> Signed-off-by: loli10K <[email protected]> Closes #7131
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a4dccdda6..07d583fdf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,7 +41,7 @@ dist-hook:
sed -i 's/Release:[[:print:]]*/Release: $(RELEASE)/' \
$(distdir)/META
-checkstyle: cstyle shellcheck flake8 commitcheck mancheck
+checkstyle: cstyle shellcheck flake8 commitcheck mancheck testscheck
commitcheck:
@if git rev-parse --git-dir > /dev/null 2>&1; then \
@@ -68,6 +68,14 @@ mancheck:
xargs mandoc -Tlint -Werror; \
fi
+testscheck:
+ @find ${top_srcdir}/tests/zfs-tests/tests -type f \
+ \( -name '*.ksh' -not -executable \) -o \
+ \( -name '*.kshlib' -executable \) -o \
+ \( -name '*.cfg' -executable \) | \
+ xargs -r stat -c '%A %n' | \
+ awk '{c++; print} END {if(c>0) exit 1}'
+
lint: cppcheck paxcheck
cppcheck: