aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorloli10K <[email protected]>2019-01-15 20:56:29 +0100
committerBrian Behlendorf <[email protected]>2019-01-15 11:56:29 -0800
commit7b02fae7a6670579437d1fb490362f70168b0666 (patch)
tree42c7caa3cccdc6d24bdf1c47a89f52ed6def0fc4 /Makefile.am
parent9b626c126e78cdc36200b66c7cd1dc6a06cf400d (diff)
Verify .gitignore entries
This change adds a make target 'vcscheck' which scans the git workspace for new, untracked files missing from the .gitignore configuration; this is done to help prevent adding unwanted build artifacts to the source tree during development. Reviewed-by: Neal Gompa <[email protected]> Reviewed-by: Giuseppe Di Natale <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: loli10K <[email protected]> Closes #8281
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 43891af71..02e104434 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,7 @@ install-data-hook:
ln -fs zfs.release spl.release
endif
-codecheck: cstyle shellcheck flake8 mancheck testscheck
+codecheck: cstyle shellcheck flake8 mancheck testscheck vcscheck
checkstyle: codecheck commitcheck
@@ -117,6 +117,12 @@ testscheck:
xargs -r stat -c '%A %n' | \
awk '{c++; print} END {if(c>0) exit 1}'
+vcscheck:
+ @if git rev-parse --git-dir > /dev/null 2>&1; then \
+ git ls-files . --exclude-standard --others | \
+ awk '{c++; print} END {if(c>0) exit 1}' ; \
+ fi
+
lint: cppcheck paxcheck
cppcheck: