aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2009-03-10 10:57:52 -0700
committerBrian Behlendorf <[email protected]>2009-03-11 12:37:34 -0700
commit0c617c9a63c733643019a8d930d902ce56b153cc (patch)
tree06495996357201096190238070b4da05dd141f4e /Makefile.am
parentd4326403de5f1fe9634c3d9468a51076eff702b6 (diff)
Build system cleanup
1) Undefine non-unique entries in spl_config.h 2) Minor Makefile cleanup 3) Don't use includedir for proper kernel header install
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 410d9a689..37182fe7f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,8 @@
SUBDIRS = lib cmd module include scripts
AUTOMAKE_OPTIONS = foreign dist-zip
-EXTRA_DIST = autogen.sh spl.spec META DISCLAIMER
-include_HEADERS = spl_config.h
+EXTRA_DIST = autogen.sh spl.spec.in META DISCLAIMER
+noinst_HEADERS = spl_config.h
distclean-local::
-$(RM) -R autom4te*.cache
@@ -16,7 +16,7 @@ distclean-local::
-type f -print | xargs $(RM)
install-data-local:
- $(INSTALL) module/Module.symvers $(DESTDIR)/$(includedir)
+ $(INSTALL) -D spl_config.h $(DESTDIR)/$(LINUX)/include/spl/spl_config.h
ctags:
$(RM) $(top_srcdir)/tags