aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Di Natale <[email protected]>2017-03-09 17:40:21 -0800
committerBrian Behlendorf <[email protected]>2017-03-09 17:40:21 -0800
commit589bb918ef39058b1f06da72092e895835a7aaff (patch)
treebc5cdc05e6f334fef7b20e2d6ec53fcb9bd7c605 /Makefile.am
parentc3d043817305efebce89db5d9146e70807c4043b (diff)
Suppress cppcheck nullPointer error in zfs_write
Newer versions of cppcheck find the potential NULL pointer bug in zfs_write(). The function is difficult to refactor without extensive work, so suppress the potential NULL pointer error which cannot occur for now. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Giuseppe Di Natale <[email protected]> Closes #5882
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2cd2aabc5..3adc161ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,7 +62,8 @@ lint: cppcheck paxcheck
cppcheck:
@if type cppcheck > /dev/null 2>&1; then \
- cppcheck --quiet --force --error-exitcode=2 ${top_srcdir}; \
+ cppcheck --inline-suppr --quiet --force --error-exitcode=2 \
+ ${top_srcdir}; \
fi
paxcheck: