summaryrefslogtreecommitdiffstats
path: root/tests/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/glx/Makefile.am')
-rw-r--r--tests/glx/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/glx/Makefile.am b/tests/glx/Makefile.am
new file mode 100644
index 00000000000..0b061176e1a
--- /dev/null
+++ b/tests/glx/Makefile.am
@@ -0,0 +1,16 @@
+AM_CFLAGS = -I$(top_builddir)/src/glx -I$(top_builddir)/src/mapi \
+ $(X11_CFLAGS) $(GTEST_CFLAGS)
+AM_CXXFLAGS = -I$(top_builddir)/src/glx -I$(top_builddir)/src/mapi \
+ $(X11_CFLAGS) $(GTEST_CFLAGS)
+
+if HAVE_GTEST
+TESTS = glx_unittest
+check_PROGRAMS = glx_unittest
+
+glx_unittest_SOURCES = \
+ clientinfo_unittest.cpp \
+ create_context_unittest.cpp \
+ fake_glx_screen.cpp
+
+glx_unittest_LDADD = $(top_builddir)/src/glx/libglx.a $(GTEST_LIBS) -lgtest_main
+endif \ No newline at end of file