summaryrefslogtreecommitdiffstats
path: root/src/vulkan/overlay-layer/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/vulkan/overlay-layer/meson.build')
-rw-r--r--src/vulkan/overlay-layer/meson.build62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/vulkan/overlay-layer/meson.build b/src/vulkan/overlay-layer/meson.build
new file mode 100644
index 00000000000..573983e0438
--- /dev/null
+++ b/src/vulkan/overlay-layer/meson.build
@@ -0,0 +1,62 @@
+# Copyright © 2019 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+vklayer_install_dir = join_paths(get_option('prefix'), 'share', 'vulkan', 'explicit_layer.d')
+
+glslang = find_program('glslangValidator')
+
+overlay_shaders = [
+ 'overlay.frag',
+ 'overlay.vert',
+]
+overlay_spv = []
+foreach s : ['overlay.frag', 'overlay.vert']
+ overlay_spv += custom_target(
+ s + '.spv.h', input : s, output : s + '.spv.h',
+ command : [glslang, '-V', '-x', '-o', '@OUTPUT@', '@INPUT@'])
+endforeach
+
+vklayer_files = files(
+ 'overlay.cpp',
+ 'vk_layer_table.cpp',
+)
+
+vklayer_mesa_overlay = shared_library(
+ 'VkLayer_MESA_overlay',
+ vklayer_files, overlay_spv,
+ c_args : [c_vis_args, no_override_init_args],
+ cpp_args : [cpp_vis_args],
+ dependencies : [libimgui_core_dep, dep_dl],
+ include_directories : [inc_common, inc_vulkan_util],
+ link_args : cc.get_supported_link_arguments(['-Wl,-Bsymbolic-functions', '-Wl,-z,relro']),
+ link_with : [libmesa_util, libvulkan_util],
+ install_dir : vklayer_install_dir,
+)
+
+sdata = configuration_data()
+sdata.set('install_dir', vklayer_install_dir)
+
+configure_file(
+ input : 'VkLayer_MESA_overlay.json.in',
+ output : '@BASENAME@',
+ configuration : sdata,
+ install_dir : vklayer_install_dir,
+ install : true
+)