summaryrefslogtreecommitdiffstats
path: root/src/util/xmlpool/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/xmlpool/meson.build')
-rw-r--r--src/util/xmlpool/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/util/xmlpool/meson.build b/src/util/xmlpool/meson.build
index d0ecec4937f..9d9ab8a0bf8 100644
--- a/src/util/xmlpool/meson.build
+++ b/src/util/xmlpool/meson.build
@@ -25,7 +25,7 @@ foreach lang : _langs
_langs_po_files += files(lang + '.po')
endforeach
-xmlpool_options_h = custom_target(
+_xmlpool_options_h = custom_target(
'xmlpool_options.h',
input : ['gen_xmlpool.py', 't_options.h'],
output : 'options.h',
@@ -36,6 +36,11 @@ xmlpool_options_h = custom_target(
depend_files : _langs_po_files,
)
+idep_xmlconfig_headers = declare_dependency(
+ sources : _xmlpool_options_h,
+ include_directories : inc_util,
+)
+
if host_machine.system() != 'windows'
i18n = import('i18n')
i18n.gettext('xmlpool', install : false)