summaryrefslogtreecommitdiffstats
path: root/src/util/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/meson.build')
-rw-r--r--src/util/meson.build49
1 files changed, 27 insertions, 22 deletions
diff --git a/src/util/meson.build b/src/util/meson.build
index 225593f5d38..fa591c92e56 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -118,34 +118,39 @@ libxmlconfig = static_library(
)
if with_tests
- u_atomic_test = executable(
- 'u_atomic_test',
- files('u_atomic_test.c'),
- include_directories : inc_common,
- link_with : libmesa_util,
- c_args : [c_msvc_compat_args],
+ test(
+ 'u_atomic',
+ executable(
+ 'u_atomic_test',
+ files('u_atomic_test.c'),
+ include_directories : inc_common,
+ link_with : libmesa_util,
+ c_args : [c_msvc_compat_args],
+ )
)
- roundeven_test = executable(
- 'roundeven_test',
- files('roundeven_test.c'),
- include_directories : inc_common,
- c_args : [c_msvc_compat_args],
- dependencies : [dep_m],
+ test(
+ 'roundeven',
+ executable(
+ 'roundeven_test',
+ files('roundeven_test.c'),
+ include_directories : inc_common,
+ c_args : [c_msvc_compat_args],
+ dependencies : [dep_m],
+ )
)
- mesa_sha1_test = executable(
- 'mesa-sha1_test',
- files('mesa-sha1_test.c'),
- include_directories : inc_common,
- link_with : libmesa_util,
- c_args : [c_msvc_compat_args],
+ test(
+ 'mesa-sha1',
+ executable(
+ 'mesa-sha1_test',
+ files('mesa-sha1_test.c'),
+ include_directories : inc_common,
+ link_with : libmesa_util,
+ c_args : [c_msvc_compat_args],
+ )
)
- test('u_atomic', u_atomic_test)
- test('roundeven', roundeven_test)
- test('mesa-sha1', mesa_sha1_test)
-
subdir('tests/hash_table')
subdir('tests/string_buffer')
endif