summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c7e183e8d61..03b619efeb7 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -31,12 +31,19 @@ libmesautil_la_CPPFLAGS = \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa \
+ $(SHA1_CFLAGS) \
$(VISIBILITY_CFLAGS)
libmesautil_la_SOURCES = \
$(MESA_UTIL_FILES) \
$(MESA_UTIL_GENERATED_FILES)
+if HAVE_SHA1
+libmesautil_la_SOURCES += $(MESA_UTIL_SHA1_FILES)
+endif
+
+libmesautil_la_LIBADD = $(SHA1_LIBS)
+
check_PROGRAMS = u_atomic_test
TESTS = $(check_PROGRAMS)