summaryrefslogtreecommitdiffstats
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build60
1 files changed, 59 insertions, 1 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index 6b167d04b9c..9c12ff8fd8e 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -19,6 +19,64 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
-inc_panfrost = include_directories(['.', 'shared'])
+inc_panfrost_hw = include_directories([
+ 'include'
+])
+
+inc_panfrost = include_directories([
+ '.', 'include', 'shared', 'midgard', 'bifrost'
+])
subdir('shared')
+subdir('midgard')
+subdir('bifrost')
+subdir('pandecode')
+
+files_pandecode = files(
+ 'pandecode/cmdline.c',
+ 'pandecode/common.c',
+ 'pandecode/decode.c',
+ 'pandecode/pan_pretty_print.c',
+
+ 'midgard/disassemble.c',
+ 'midgard/midgard_ops.c',
+ 'bifrost/disassemble.c',
+)
+
+pandecode = executable(
+ 'pandecoder',
+ files_pandecode,
+ include_directories : [inc_common, inc_include, inc_src, inc_panfrost],
+ dependencies : [
+ dep_thread,
+ ],
+ link_with : [
+ libmesa_util
+ ],
+ build_by_default : true
+)
+
+files_bifrost = files(
+ 'bifrost/cmdline.c',
+)
+
+bifrost_compiler = executable(
+ 'bifrost_compiler',
+ [files_bifrost],
+ include_directories : [
+ inc_common,
+ inc_include,
+ inc_src,
+ inc_panfrost,
+ ],
+ dependencies : [
+ dep_thread,
+ idep_nir
+ ],
+ link_with : [
+ libglsl_standalone,
+ libmesa_util,
+ libpanfrost_bifrost
+ ],
+ build_by_default : true
+)