summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 186cf92f47e..53c8269a99e 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -66,3 +66,17 @@ if with_egl
subdir('egl')
endif
subdir('gallium')
+
+# This must be after at least mesa, glx, and gallium, since libgl will be
+# defined in one of those subdirs depending on the glx provider.
+if with_glx != 'disabled'
+ pkg.generate(
+ name : 'gl',
+ description : 'Mesa OpenGL Library',
+ version : meson.project_version(),
+ libraries : libgl,
+ libraries_private : gl_priv_libs,
+ requires_private : gl_priv_reqs,
+ variables : ['glx_tls=yes'],
+ )
+endif