summaryrefslogtreecommitdiffstats
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 20d06aad4dd..b839fd02981 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -19,15 +19,10 @@
# SOFTWARE.
# TODO: main/tests
-# TODO: xlib_glx
-# TODO: osmesa
-# TODO: asm_offsets
subdir('program')
subdir('main')
-# program files
-# program nir files
# files shared between classic mesa and gallium mesa
files_libmesa_common = files(
'program/arbprogparse.c',
@@ -721,6 +716,9 @@ subdir('drivers/dri')
if with_osmesa == 'classic'
subdir('drivers/osmesa')
endif
+if with_glx == 'xlib'
+ subdir('drivers/x11')
+endif
if with_tests
subdir('main/tests')
endif