summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/x11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/x11/Makefile.am')
-rw-r--r--src/mesa/drivers/x11/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/mesa/drivers/x11/Makefile.am b/src/mesa/drivers/x11/Makefile.am
index b10e86f534a..27343d15791 100644
--- a/src/mesa/drivers/x11/Makefile.am
+++ b/src/mesa/drivers/x11/Makefile.am
@@ -58,10 +58,11 @@ GL_PATCH = 0
lib@GL_LIB@_la_LIBADD = \
$(top_builddir)/src/mesa/libmesa.la \
- $(top_builddir)/src/mapi/glapi/libglapi.la
+ $(top_builddir)/src/mapi/glapi/libglapi.la \
+ $(GL_LIB_DEPS)
+
lib@GL_LIB@_la_LDFLAGS = \
-version-number $(GL_MAJOR):$(GL_MINOR):$(GL_PATCH) \
- -no-undefined \
- $(GL_LIB_DEPS)
+ -no-undefined
include $(top_srcdir)/install-lib-links.mk