summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/x11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/x11/Makefile.am')
-rw-r--r--src/mesa/drivers/x11/Makefile.am82
1 files changed, 0 insertions, 82 deletions
diff --git a/src/mesa/drivers/x11/Makefile.am b/src/mesa/drivers/x11/Makefile.am
deleted file mode 100644
index 3024c549e61..00000000000
--- a/src/mesa/drivers/x11/Makefile.am
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright © 2012 Intel Corporation
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-# IN THE SOFTWARE.
-
-# This builds "stand-alone" Mesa, a version of libGL that does not need the
-# GLX extension. All rendering is converted to Xlib calls. No hardware
-# acceleration.
-
-EXTRA_DIST = SConscript meson.build
-
-if HAVE_SHARED_GLAPI
-SHARED_GLAPI_LIB = $(top_builddir)/src/mapi/shared-glapi/libglapi.la
-endif
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src/mapi \
- -I$(top_srcdir)/src/mesa \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/auxiliary \
- -I$(top_srcdir)/src/mesa/main \
- $(X11_INCLUDES) \
- $(DEFINES)
-
-lib_LTLIBRARIES = lib@[email protected]
-
-lib@GL_LIB@_la_SOURCES = \
- glxapi.h \
- glxheader.h \
- xfonts.h \
- xmesaP.h \
- fakeglx.c \
- glxapi.c \
- xfonts.c \
- xm_api.c \
- xm_buffer.c \
- xm_dd.c \
- xmesa.h \
- xmesa_x.h \
- xm_line.c \
- xm_tri.c
-
-# Force usage of a C++ linker
-nodist_EXTRA_lib@GL_LIB@_la_SOURCES = dummy.cpp
-
-GL_MAJOR = 1
-GL_MINOR = 6
-GL_PATCH = 0
-
-lib@GL_LIB@_la_LIBADD = \
- $(top_builddir)/src/mesa/libmesa.la \
- $(top_builddir)/src/mapi/glapi/libglapi.la \
- $(top_builddir)/src/util/libmesautil.la \
- $(SHARED_GLAPI_LIB) \
- $(GL_LIB_DEPS)
-
-lib@GL_LIB@_la_LDFLAGS = \
- -no-undefined \
- -version-number $(GL_MAJOR):$(GL_MINOR):$(GL_PATCH) \
- $(BSYMBOLIC) \
- $(GC_SECTIONS) \
- $(LD_NO_UNDEFINED)
-
-include $(top_srcdir)/install-lib-links.mk