summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
index 1ceff886d01..db1d14fe80e 100644
--- a/src/mesa/drivers/osmesa/Makefile.am
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -40,12 +40,14 @@ lib@OSMESA_LIB@_la_LIBADD = \
$(top_builddir)/src/mesa/libmesa.la \
$(top_builddir)/src/mapi/glapi/libglapi.la
+if BUILD_SHARED
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.
all-local: lib@[email protected]
$(MKDIR_P) $(top_builddir)/$(LIB_DIR);
ln -f .libs/lib@[email protected] $(top_builddir)/$(LIB_DIR)/lib@[email protected];
ln -f .libs/lib@[email protected].@VERSION@ $(top_builddir)/$(LIB_DIR)/lib@[email protected].@VERSION@;
+endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = osmesa.pc