summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/glapi/meson.build')
-rw-r--r--src/mapi/glapi/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/mapi/glapi/meson.build b/src/mapi/glapi/meson.build
index 267cfe7e7be..e241d9ed388 100644
--- a/src/mapi/glapi/meson.build
+++ b/src/mapi/glapi/meson.build
@@ -82,9 +82,10 @@ if not with_shared_glapi and with_tests
'glapi_static_check_table',
executable(
'glapi_static_check_table',
- 'tests/check_table.cpp',
+ ['tests/check_table.cpp', glapitable_h],
+ include_directories : [inc_include, inc_src, inc_mesa, inc_mapi],
link_with : [libglapi_static],
- dependencies : [idep_gtest],
+ dependencies : [idep_gtest, dep_thread],
)
)
endif