summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/glapi/meson.build')
-rw-r--r--src/mapi/glapi/meson.build82
1 files changed, 82 insertions, 0 deletions
diff --git a/src/mapi/glapi/meson.build b/src/mapi/glapi/meson.build
new file mode 100644
index 00000000000..d09cf94e36f
--- /dev/null
+++ b/src/mapi/glapi/meson.build
@@ -0,0 +1,82 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+static_glapi_files = []
+static_glapi_args = []
+
+if with_appledri or with_windowsdri
+ static_glapi_files += files('glapi_gentable.c')
+endif
+
+if with_shared_glapi
+ static_glapi_files += files(
+ '../entry.c',
+ '../entry.h',
+ '../entry_x86-64_tls.h',
+ '../entry_x86_tls.h',
+ '../entry_x86_tsd.h',
+ '../entry_ppc64le_tls.h',
+ '../entry_ppc64le_tsd.h',
+ '../mapi_tmp.h',
+ )
+ static_glapi_files += glapi_mapi_tmp_h
+ static_glapi_args += [
+ '-DMAPI_MODE_BRIDGE',
+ '-DMAPI_ABI_HEADER="@0@"'.format(glapi_mapi_tmp_h.full_path()),
+ ]
+else
+ static_glapi_args += '-DMAPI_MODE_UTIL'
+ static_glapi_files += files(
+ 'glapi_dispatch.c',
+ 'glapi_entrypoint.c',
+ 'glapi_getproc.c',
+ 'glapi_nop.c',
+ 'glapi.c',
+ 'glapi.h',
+ 'glapi_priv.h',
+ )
+ static_glapi_files += files_mapi_util
+ if with_asm_arch == 'x86'
+ static_glapi_files += glapi_x86_s
+ elif with_asm_arch == 'x86_64'
+ static_glapi_files += glapi_x86_64_s
+ endif
+ # TODO: SPARC asm
+endif
+
+libglapi_static = static_library(
+ 'glapi_static',
+ static_glapi_files,
+ include_directories : [inc_mesa, inc_include, inc_src],
+ c_args : [c_msvc_compat_args, static_glapi_args],
+ dependencies : [dep_thread, dep_selinux],
+ build_by_default : false,
+)
+
+if not with_shared_glapi and with_tests
+ glapi_static_check_table = executable(
+ 'glapi_static_check_table',
+ 'tests/check_table.cpp',
+ link_with : [libglapi_static],
+ dependencies : [idep_gtest],
+ )
+
+ test('glapi_static_check_table', glapi_static_check_table)
+endif