summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/glapi/meson.build')
-rw-r--r--src/mapi/glapi/meson.build13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/mapi/glapi/meson.build b/src/mapi/glapi/meson.build
index 8856a95fb66..267cfe7e7be 100644
--- a/src/mapi/glapi/meson.build
+++ b/src/mapi/glapi/meson.build
@@ -78,12 +78,13 @@ libglapi_static = static_library(
)
if not with_shared_glapi and with_tests
- glapi_static_check_table = executable(
+ test(
'glapi_static_check_table',
- 'tests/check_table.cpp',
- link_with : [libglapi_static],
- dependencies : [idep_gtest],
+ executable(
+ 'glapi_static_check_table',
+ 'tests/check_table.cpp',
+ link_with : [libglapi_static],
+ dependencies : [idep_gtest],
+ )
)
-
- test('glapi_static_check_table', glapi_static_check_table)
endif