summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/intel/vulkan/meson.build')
-rw-r--r--src/intel/vulkan/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/intel/vulkan/meson.build b/src/intel/vulkan/meson.build
index debdcce4ef2..606a4898fe2 100644
--- a/src/intel/vulkan/meson.build
+++ b/src/intel/vulkan/meson.build
@@ -48,6 +48,18 @@ intel_icd = custom_target(
install : true,
)
+dev_icd = custom_target(
+ 'dev_icd',
+ input : 'anv_icd.py',
+ output : 'dev_icd.@[email protected]'.format(host_machine.cpu()),
+ command : [prog_python2, '@INPUT@',
+ '--lib-path', meson.current_build_dir(),
+ '--out', '@OUTPUT@'],
+ depend_files : files('anv_extensions.py'),
+ build_by_default : true,
+ install : false,
+)
+
# TODO: workaround for anv_entrypoints combining the .h and .c files in it's
# output. See issue #2346
block_entrypoints = custom_target(